Uploaded image for project: 'GMAT'
  1. GMAT
  2. GMT-7039

Simulator sometimes causes an infinite loop

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: P1
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: R2019a
    • Component/s: Nav
    • Labels:

      Description

      The RunSimulator command seems to trigger an infinite loop in some cases when paired with a propagation step. The attached script is a minimum working example that recreates the problem. This script should be able to run without any changes for the local machine.

      Here's the most relevant part of the script:

      Create Simulator Station1_0_simulator;
      GMAT Station1_0_simulator.AddData = {Station1_0_data};
      GMAT Station1_0_simulator.Propagator = ODProp;
      GMAT Station1_0_simulator.EpochFormat = UTCGregorian;
      GMAT Station1_0_simulator.InitialEpoch = '11 Oct 2019 00:05:49.383';
      GMAT Station1_0_simulator.FinalEpoch = '11 Oct 2019 00:06:49.383';
      GMAT Station1_0_simulator.MeasurementTimeStep = 10;
      GMAT Station1_0_simulator.AddNoise = Off;
      
      Create TrackingFileSet Station1_0_data;
      GMAT Station1_0_data.AddTrackingConfig = {{Station1,EstSat,Station1},Azimuth,Elevation};
      GMAT Station1_0_data.FileName = {Station1_0_measurements.gmd};
      GMAT Station1_0_data.UseLightTime = true;
      GMAT Station1_0_data.UseRelativityCorrection = false;
      GMAT Station1_0_data.UseETminusTAI = false;
      GMAT Station1_0_data.AberrationCorrection = 'AnnualAndDiurnal';
      
      BeginMissionSequence
      
      Propagate BackProp ODProp(EstSat) {EstSat.ElapsedDays = -3};
      RunSimulator Station1_0_simulator;
      

      For context, I am programatically generating GMAT scripts in order to simulate several batches of data in parallel. Some of the batches I need to simulate are for epochs prior to the Spacecraft state epoch, so I have to back propagate first (or else I'll get stuck in another infinite loop). To be safe, I just added a back propagation line to all of the scripts with a duration that would ensure the simulated spans are always later than the current internal Spacecraft epoch. In general, this process has worked – out of ~19 batches, only this one failed. When this problem happened initially, the script ran for just under 24 hours with no visible file output or increased memory usage.

      I tried changing settings and removing other parts of the script without success. The only way to resolve the problem is to change the back propagation span to a duration less than 3 days.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: