Uploaded image for project: 'GMAT'
  1. GMAT
  2. GMT-6514

No Optimizer Options/ Cannot Add Optimizer

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: P1
    • Resolution: Fixed
    • Affects Version/s: R2016a
    • Fix Version/s: None
    • Component/s: GUI
    • Labels:
      None

      Description

      When right-clicking "Optimizers" in the "Solvers" folder of the "Resources" Tree, nothing shows up after hovering over "Add".

      I am following the Lunar Fly-By tutorial, and it assumes I have the VF13ad optimizer files? I tried manually adding/creating the optimizer by adding the provided text to the script of the mission that I'm working on, but that gave errors. There is another bug which has those errors, but no solution was provided and it was closed with no explanation.

      I attempted to search for plugins for GMAT, but all the links point to an old 2013 site that contains no files.

        Gliffy Diagrams

          Attachments

            Activity

            gustolph Niklas Anthony added a comment -

            Does not work for 2017a build either.

            djcinsb Darrel Conway added a comment - - edited

            Optimizers in GMAT are a known issue that we are addressing with GMAT R2018a. The problem is that the optimizers that GMAT supports all have licenses that prevent us from releasing their plugins with GMAT. The closest we can come in the R2017a and earlier releases is the fmincon optimizer, which requires that the user purchase MATLAB's optimization toolbox, and that only works on Windows. (I run on Linux, so cannot use it.)

            In R2018a, we are adding an optimizer to the system, Yukon, coded by the GMAT development team, that solves the same class of problems that VF13ad solves. GMAT R2018a should be out soon. We are currently testing the third release candidate, and if it looks solid on our target platforms, we'll be able to make it available to the public.

            gustolph Niklas Anthony added a comment -

            Ah I see. I do have MATLAB, thanks!


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: