Uploaded image for project: 'GMAT'
  1. GMAT
  2. GMT-6414

Create a Watch Window for GMAT Runs

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: P1
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: R2019a
    • Component/s: GUI
    • Labels:

      Description

      GMAT needs a new subscriber that shows the values of parameters as they are updated during a run. This feature will be part of R2019a.

        Gliffy Diagrams

          Attachments

            Activity

            shughes Steven Hughes added a comment -

            Here is a link to the spec template: https://docs.google.com/document/d/1VEdcjTGwQWzIIe3d3yWwvajQ0p14ovk66P_LOOdz0oc/edit#heading=h.hxo3r8n7dvbv
            we need to write a spec for how this feature will work.

            The spec document can also be found here under Output and Utility Specifications:
            http://li394-117.members.linode.com:8090/display/GW/Functional+Specifications

            shughes Steven Hughes added a comment - - edited
            • The user should be able to add rows of data to a dynamic display window that has a look and feel similar to the target status window.
            • it is desirable for the user able to set the color of the font during initial object configuration or mission execution. Default color is black.

            Note, this is a first cut at a design, if you think of something better, great.

            Create Variable myVar
            Create Array myArray[3,3]
            Create DynamicDataDisplay myData
            myData.AddRow = {mySat.SMA,'Blue', myVar, myArray(2,2)}
            myData.AddRow = {mySat.X, mySat.Y}
            
            BeginMissionSequence
            
            %  Non-standard scripting, gets the point across but may need to be modified for consistency and parsing
            myData.Row(1).SetColor = {Blue, Yellow, Red}
            

            Colors are optional. Use the build in color spec used by "OrbitColor" and "TargetColor" on spacecraft. That already has a mapping between strings and the RGB color values.

            shughes Steven Hughes added a comment -

            Needs RenameRefObject().
            DynamicDisplay window is not handled in the special case code like CloseAllWindows.

            djcinsb Darrel Conway added a comment -

            A few notes from Josh on remaining work:

            1. When making example scripts I rand into an unhandled exception, I made sure to save that version of the script so I can go track it down.

            2, Currently, the error message in UpdateDynamicDisplay for an incorrect DynamicDataDisplay being entered or entering an incorrect parameter does not trigger a warning until the mission is run. I will see if I can get this error to appear when the script is saved rather than later.

            3. There is currently no clean way to remove data in a particular cell using the GUI setup panel for the DynamicDataDisplay. I am going to see if I can either make the cell reset to defaults by either using the Delete key or possibly by having the user right click on the cell and select a "Clear" option.

            jraymond Joshua Raymond added a comment -

            I have attached scripts that can be used to see the various settings for DynamicDataDisplay being used that correspond to the GUI test ideas I have added in the spec of this resource. Note that currently the TextColor setting cannot be set during the mission sequence since it is a StringArray type which causes issues in Assignment.cpp.

            troyzman Tetyana Royzman added a comment -

            Tested the dynamic Data Display with the latest build (5/7/18)

            troyzman Tetyana Royzman added a comment -

            Working on creating the System test for each script attached in this ticket for the future Regression verification.

            troyzman Tetyana Royzman added a comment -

            Created all system tests from the scripts to verify different settings for DynamicDataDisplay.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 1 week, 2 days Original Estimate - 1 week, 2 days
                  1w 2d
                  Remaining:
                  Time Spent - 3 weeks, 3 days, 3 hours Remaining Estimate - 1 day, 6 hours
                  1d 6h
                  Logged:
                  Time Spent - 3 weeks, 3 days, 3 hours Remaining Estimate - 1 day, 6 hours
                  3w 3d 3h