Uploaded image for project: 'GMAT'
  1. GMAT
  2. GMT-6260

'Write' Panel Does Not Behave as Expected

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: R2017a
    • Fix Version/s: None
    • Component/s: Write Command
    • Labels:
    • Environment:

      Windows 7, Build 9/28/2017

      Description

      Can specify 'True' and 'False' condition for the same option and the panel accepts it. For example:

      {MessageWindow = true, MessageWindow = false}

      When close and open panel again, it picks the latest condition.

      Also, ones ReportFile specified, the user cannot delete it although it is not a default value for this panel.

        Gliffy Diagrams

          Attachments

            Activity

            jraymond Joshua Raymond added a comment -

            A fix has been made in the Write.cpp file for the two issues listed in this ticket, found in the WritePanelBehaviorFix branch.

            It seems that the default GUI panel produces some non-intuitive behavior overall. For example, in Write, the default value for MessageWindow is set to true. Now let's say I have changed that setting to false and applied it. If later, in the GUI panel, I delete the MessageWindow = false entirely and apply that change, the option will still be set to false instead of resetting to its default, true. A possible reason for this is because if a change is made in the script itself, the Gmat code makes an entirely new pointer for the command, while for changes in the default GUI panel, the Gmat code simply uses the already created pointer with whatever current settings are on the command.

            djcinsb Darrel Conway added a comment -

            We need to know expected behavior for this panel, as can be seen in Josh's comment above. Specifically, if a non-default setting is removed from the panel, should the command fall back to the default behavior or preserve the behavior it had when the script was loaded? Please comment (or pass to someone else that can comment), and then return the issue to either me or Josh.

            shughes Steven Hughes added a comment -

            Make the panel behave like the script.

            jraymond Joshua Raymond added a comment -

            GUI panel now behaves like the script. Ticket is ready for review.

            shughes Steven Hughes added a comment -

            Hi Tetyana, we believe this is fixed. Can you verify in a nighyly build?

            troyzman Tetyana Royzman added a comment -

            Tested with 11/29 Build. GMAT throws the error if the user sets any option more than ones.

            troyzman Tetyana Royzman added a comment -

            The issue fixed.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 4 hours
                  4h
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 4 hours
                  4h