Uploaded image for project: 'GMAT'
  1. GMAT
  2. GMT-5874

Crash caused by uninitialized BorderGroupCount in GLStars

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: P3
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: R2017a
    • Component/s: GUI
    • Labels:
      None
    • Environment:

      R2015a; Windows 7; MSVS Community 2013; Debug build

      Description

      In R2015a, the BorderGroupCount member variable in the GLStars class does not appear to be initialized anywhere. In a debug build in VS2013, GLStars::ReadBorders thus crashes when indexing an array using this variable. This can be seen when initially opening an OrbitView.

      It seems as though the existing code expects this variable to be initialized to 0 before ReadBorders does any work. A patch is attached that fixes the issue.

        Gliffy Diagrams

          Attachments

            Activity

            tgrubb Thomas Grubb added a comment -

            Status 2016-10-21 - No work performed.

            bet Bryan Topp added a comment -

            Seems to have already been fixed in R2016a.

            tgrubb Thomas Grubb added a comment -

            Hi Bryan,
            As you noticed, this issue looks like it is fixed. BorderGroupCount is initialized in the constructor now and was fixed in Jan 2016. Thank you for your help.
            Tom

            tgrubb Thomas Grubb added a comment -

            Duplicate of GMT-5449


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 4 hours
                  4h
                  Remaining:
                  Remaining Estimate - 4 hours
                  4h
                  Logged:
                  Time Spent - Not Specified
                  Not Specified