Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: P1
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: R2016a
    • Component/s: GUI
    • Labels:
      None

      Description

      GMAT 64 bit can be made to crash easily, at least on my machine, by:

      • Start GMAT 64 bit
      • Click New Script button
      • Close Welcome Page
      • Close Script Window using Close button
      • Boom

      Another way

      • Start GMAT
      • Add Report File
      • Run GMAT Mission
      • Open Report File in GMAT
      • Close Report File Window using Close button
      • Boom

      It looks like it happens in wx (3.0.2) code.

      I cannot reproduce this on LatestCompleteVersion 32 bit. Someone needs to confirm this for 64 bit.

        Gliffy Diagrams

          Attachments

            Activity

            shughes Steven Hughes added a comment -

            Since Ravi can use C-make to build 64 bit, can you see if he sees this from Cmake builds?

            djcinsb Darrel Conway added a comment -

            Linux note: I don't see this crash on Linux, but on Linux there is no window "X" widget to close the window (since MDI is implemented as tab views in wx on Linux, so there is no window title bar with close, minimize, maximize buttons). I tried closing with the available options.

            ravidavi Ravi Mathur added a comment -

            I have noticed for a long time now, that using the "x" button to close a window on Windows crashes GMAT. This happens almost no matter what type of window it is (script, options panel, etc...).

            I didn't realize it was a 64-bit issue until just now though. I can confirm that it doesn't happen on the LatestCompleteVersion (32-bit), but does happen on my CMake-created 64-bit builds.

            shughes Steven Hughes added a comment -

            This is related to an old issue GMT-5243. Look there for hints.

            tgrubb Thomas Grubb added a comment -

            Should be in 2016-08-02 build

            shughes Steven Hughes added a comment -

            Ran full test system and stability if fine.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: